Home » Info: Moodle System Requirements

Info: Moodle System Requirements

System requirements

Since Moodle 2.0 is such a major release, we are allowing ourselves some increases in the requirements.

  • PHP must be 5.2.8 or later (it was released 08-Dec-2008)
  • Databases should be one of the following:
    • MySQL 5.0.25 or later (InnoDB storage engine highly recommended)
    • PostgreSQL 8.3 or later
    • Oracle 10.2 or later
    • MS SQL 2005 or later
  • Any standards-supporting browser from the past few years, for example: